Several vulnerabilities in extension phpMyAdmin (phpmyadmin)

It has been discovered that the extension "phpMyAdmin" (phpmyadmin) is susceptible to Cross-Site Scripting and Cross-Site Request Forgery.

Release Date: September 26, 2014

Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.

Affected Versions: version 4.18.2 and below

Vulnerability Type: XSS, CSRF

Severity: Medium

Suggested CVSS v2.0: AV:N/AC:M/Au:S/C:P/I:P/A:N/E:ND/RL:O/RC:C (What's that?)

References: PMASA-2014-8, PMASA-2014-10

Problem Description: With several usage actions it is possible to trigger XSS in various components. By deceiving a logged-in user to click on a crafted URL, it is possible to perform remote code execution and in some cases, create a root account due to a DOM based XSS vulnerability in the micro history feature.

Solution: An updated version 4.18.3 is available from the TYPO3 extension manager and at Users of the extension are advised to update the extension as soon as possible.

Credits: The vendor of the phpMyAdmin upstream software credits Ashutosh Dhundhara (PMASA-2014-8) and Olivier Beg (PMASA-2014-8). Thanks to Andreas Beutel for providing a TYPO3 extension package with an updated phpMyAdmin version.

General advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list to receive future Security Bulletins via E-mail.