Cross-site scripting vulnerability in extension Seminars (seminars)

It has been discovered that the extension "Seminars" (seminars) is vulnerable to cross-site scripting.

Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.

Affected Versions: Version 0.9.3 and below

Vulnerability Type: Cross-site scripting

Severity: Medium

Suggested CVSS v2.0: AV:N/AC:M/Au:S/C:P/I:P/A:N/E:P/RL:O/RC:C (What's that?)

Release Date: July 3rd, 2012

Problem Description: Failing to properly sanitize some record data in the FE and BE, seminars is susceptible to cross-site scripting.

Solution: An updated version 0.9.4 is available from the TYPO3 extension manager and at

Due to some changes related to the security update of ameos_formidable, the HTML template for the registration form needed to be changed. If you are using a modified HTML template for the registration form, please read the extension manual concerning how you will need to modify the HTML template.

Credits: Thanks to Alex Kellner who discovered and reported this issue.

General advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list to receive future Security Bulletins via E-mail.