Broken Access Control in extension "gForum" (g_forum)

Categories: Development , Security Created by Torben Hansen
It has been discovered that the extension "gForum" (g_forum) is susceptible to Broken Access Control.
  • Release Date: May 12, 2020
  • Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.
  • Component: gForum (ext:g_forum)
  • Vulnerability Type: Broken Access Control
  • Affected Versions: 0.0.29 and below
  • Severity: High
  • Suggested CVSS v3.1: AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N/E:F/RL:U/RC:C
  • References: None

Problem Description

The extension fails to check access rights of authenticated frontend users allowing to create, edit and delete various records of the extension without proper permission.

Solution

All versions of this extension that are known to be vulnerable will no longer be available for download from the TYPO3 Extension Repository, since the extension is abandoned and has no extension maintainer anymore.

Please uninstall and delete the extension folder from your installation and search on the TYPO3 Extension Repository for alternative extensions.

Credits

Thanks to TYPO3 security team member Torben Hansen for discovering and reporting the vulnerability.

General Advice

Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.