TYPO3-EXT-SA-2017-014: Cross Site-Scripting in extension "Multishop" (multishop)

November 07, 2017

Category: TYPO3 Extension
Author: Torben Hansen
Keywords: TYPO3, security, typo3-ext-sa-2017-014, extension, multishop, Cross-Site Scripting

It has been discovered that the extension "Multishop" (multishop) is susceptible to Cross-Site Scripting.

Release Date: November 07, 2017

Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.

Affected Versions: version 5.0.0 and below

Vulnerability Type: Cross-Site Scripting

Severity: Medium

Suggested CVSS v3.0: AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N (What's that?)

CVE: not assigned yet

Problem Description: The extension uses an old version of PHPMailer, which is known to be vulnerable to Cross-Site Scripting (CVE-2017-11503).

Solution: An updated version 5.0.1 is available from the TYPO3 Extension Manager and at https://extensions.typo3.org/extension/download/multishop/5.0.1/zip/. Users of the extension are advised to update the extension as soon as possible.

Credits: Credits go to David Münter who discovered and reported the vulnerability.

 

General advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list to receive future Security Bulletins via E-mail.