TYPO3-CORE-SA-2016-021: Cross-Site Scripting in TYPO3 Backend

September 13, 2016

Category: TYPO3 CMS
Author: Georg Ringer
Keywords: Cross-Site Scripting, Backend

It has been discovered, that TYPO3 is vulnerable to Cross-Site Scripting

Component Type: TYPO3 CMS

Release Date: September 13, 2016

 

Vulnerability Type: Cross-Site Scripting

Affected Versions: 6.2.0 to 6.2.26, 7.6.0 to 7.6.10 and 8.0.0 to 8.3.0

Severity: Low

Suggested CVSS v2.0: AV:N/AC:L/Au:S/C:P/I:P/A:N/E:F/RL:O/RC:C

CVE: not assigned yet

Problem Description: Failing to properly encode user input, the page module is vulnerable to Cross-Site Scripting. A valid backend user account with permissions to edit plugins is needed to exploit this vulnerability.

Solution: Update to TYPO3 versions 6.2.27, 7.6.11 or 8.3.1 that fix the problem described.

Credits: Thanks to Security Team Member Georg Ringer who discovered and reported the issue.

 

General Advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.

General Note: All security related code changes are tagged so that you can easily look them up on our review system.