TYPO3-CORE-SA-2016-007: Cross-Site Scripting in TYPO3 component CSS styled content

February 23, 2016

Category: TYPO3 CMS
Author: Nicole Cordes

It has been discovered, that TYPO3 is susceptible to Cross-Site Scripting.

Component Type: TYPO3 CMS

Release Date: February 23, 2016

 

Vulnerable subcomponent: CSS styled content

Vulnerability Type: Cross-Site Scripting

Affected Versions: Versions 6.2.0 to 6.2.18 and 7.6.0 to 7.6.3

Severity: Medium

Suggested CVSS v2.0: AV:N/AC:L/Au:S/C:P/I:P/A:P/E:P/RL:O/RC:C

CVE: not assigned yet

Problem Description: Failing to properly encode user input, the CSS styled content component is susceptible to Cross-Site Scripting, allowing authenticated editors to inject arbitrary HTML or JavaScript.

 

Solution: Update to TYPO3 versions 6.2.19 or 7.6.4 that fix the problem described.

Credits: Thanks to Jakub Galczyk who discovered and reported the issue.

 

General Advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.

General Note: All security related code changes are tagged so that you can easily look them up on our review system.