TYPO3-CORE-SA-2012-002: Cross-Site Scripting Vulnerability in TYPO3 Core

April 17, 2012

Category: TYPO3 CMS
Author: Helmut Hummel
Keywords: TYPO3-CORE-SA-2012-002, Cross-Site Scripting

It has been discovered that TYPO3 Core is vulnerable to Cross-Site Scripting.

Component Type: TYPO3 Core

Affected Versions: 4.4.0 up to 4.4.14, 4.5.0 up to 4.5.14, 4.6.0 up to 4.6.7 and development releases of the 4.7 branch.

Vulnerable subcomponent: Exception Handler

Vulnerability Type: Cross-Site Scripting

Severity: Medium

Suggested CVSS v2.0: AV:N/AC:L/Au:N/C:P/I:P/A:N/E:F/RL:OF/RC:C (What's that?)

CVE: CVE-2012-2112 (What's that?)

Problem Description: Failing to properly encode the output, the default TYPO3 Exception Handler is susceptible to Cross-Site Scripting.
We are not aware of a possibilty to exploit this vulnerability without third party extensions being installed that put user input in exception messages.
However it has come to our attention that extensions using the extbase MVC framework can be used to exploit this vulnerability if these extensions accept objects in controller actions.
In general and especially when in doubt if the above conditions are met, we highly recommend users of affected versions to update as soon as possible.

Imortant Note: In case you have configured your own exception handler for TYPO3 you need to make sure that the exception messages are properly encoded within this exception handler before they are presented.

Solution: Update to the TYPO3 versions 4.4.15, 4.5.15 or 4.6.8 that fix the problem described!

Credits: Credits go to Security Team Member Helmut Hummel who discovered and reported the issue.

 

 

General Advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.