TYPO3-EXT-SA-2011-004: Cross Site Scripting Vulnerability in extension Questionaire (pbsurvey)

It has been discovered that the extension "Questionaire" (pbsurvey) is vulnerable to Cross-Site Scripting.

Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.

Affected Versions: Version 1.3.0 and below

Vulnerability Types: Cross-Site Scripting

Severity: Medium

Suggested CVSS v2.0: AV:N/AC:M/Au:S/C:P/I:C/A:N/E:U/RL:OF/RC:C (What's that?)

Release Date: 25.08.2011


Problem Description: Failing to properly sanitize user input, pbsurvey is susceptible to Cross Site Scripting.

Solution: An updated version 1.3.1 is available from the TYPO3 extension manager and attypo3.org/extensions/repository/view/pbsurvey/1.3.1/.

Credits: Thanks to Security Team Member Georg Ringer who discovered and reported this issue.


General advice: Follow the recommendations that are given in the TYPO3 Security Cookbook. Please subscribe to thetypo3-announce mailing list to receive future Security Bulletins via E-mail.