TYPO3-EXT-SA-2017-017: Authentication Bypass in extension "Frontend User Registration" (sf_register)

December 19, 2017

Category: TYPO3 Extension
Author: Stephan Großberndt
Keywords: TYPO3, security, typo3-ext-sa-2017-017, extension, sf_register, Authentication Bypass

It has been discovered that the extension "Frontend User Registration" (sf_register) is vulnerable to Authentication Bypass.

Release Date: December 18, 2017

Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.

Affected Versions: version 8.8.0

Vulnerability Type: Authentication Bypass

Severity: Critical

Suggested CVSS v3.0: AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N/E:F/RL:O/RC:C (What's that?)

CVE: not assigned yet

Problem Description: The extension is vulnerable to Authentication Bypass. Frontend users can be authenticated by only knowing their username.

Solution: An updated version 8.8.1 is available from the TYPO3 Extension Manager and at https://extensions.typo3.org/extension/download/sf_register/8.8.1/zip/. Users of the extension are advised to update the extension as soon as possible.

Credits: Credits go to Manuel Glauser and Sebastian Müller who discovered and reported the vulnerability.

 

General advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list to receive future Security Bulletins via E-mail.