TYPO3-EXT-SA-2016-007: Multiple vulnerabilities in extension phpMyAdmin (phpmyadmin)

It has been discovered that the extension "phpMyAdmin" (phpmyadmin) is susceptible to unsafe comparison of XSRF/CSRF token, multiple full path disclosure vulnerabilities, multiple XSS vulnerabilities, insecure password generation in JavaScript.

Release Date: March 10, 2016

Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.

Affected Versions: 5.1.4 and below

Vulnerability Type: Unsafe Comparison of XSRF/CSRF token, Full Path Disclosure, Cross-Site Scripting, Insecure Password Generation

Severity: High

Suggested CVSS v2.0: AV:N/AC:M/Au:S/C:C/I:C/A:P/E:ND/RL:O/RC:C (What's that?)

References: PMASA-2016-2, PMASA-2016-5 (XSRF/CSRF), PMASA-2015-6, PMASA-2016-1, PMASA-2016-6 (FPD), PMASA-2016-3, PMASA-2016-7 (XSS) and PMASA-2016-4 (IPG)

Related CVE: CVE-2016-2039, CVE-2016-2041 (XSRF/CSRF), CVE-2015-8669, CVE-2016-2038, CVE-2016-2042 (FPD), CVE-2016-2040, CVE-2016-2043 (XSS) and CVE-2016-1927 (IPG)

Problem Description: Due to missing and wrong user input validation phpMyAdmin is susceptible to multiple vulnerabilities.

Solution: An updated version 5.1.5 is available from the TYPO3 extension manager and at https://typo3.org/extensions/repository/download/phpmyadmin/5.1.5/t3x/. Users of the extension are advised to update the extension as soon as possible.

Note: In general the TYPO3 Security Team recommends to not use any extension that bundles database or file management tools on production TYPO3 websites.

Credits: Thanks to Andreas Beutel for providing a TYPO3 extension package with an updated phpMyAdmin version.

General advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list to receive future Security Bulletins via E-mail.