TYPO3-EXT-SA-2015-005: Cross-Site Scripting in extension Gridelements (gridelements)

It has been discovered that the extension "gridelements" (gridelements) is susceptible to Cross-Site Scripting
Release Date: February 17, 2015
Component Type: Third party extension. This extension is not a part of the TYPO3 default installation. Affected Versions: gridelements: Versions 3.0.0, 2.1.2 and below Vulnerability Type: Cross-Site Scripting Severity: Medium Suggested CVSS v2.0: AV:N/AC:L/Au:S/C:N/I:P/A:N/E:POC/RL:OF/RC:C (What's that?) CVE: not assigned yet Problem Description: The extension fails to properly escape user input in HTML context. Backend Editor permissions with access to any text field within any data table are required to exploit this vulnerability. Solution: Updated versions 3.0.1 and 2.1.3 are available from the TYPO3 extension manager and at http://typo3.org/extensions/repository/download/gridelements/3.0.1/t3x/ and http://typo3.org/extensions/repository/download/gridelements/2.1.3/t3x/. Users of the extension are advised to update the extension as soon as possible. Credits: Credits go to Sven Jürgens who discovered and reported the issue. General advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list to receive future Security Bulletins via E-mail.