TYPO3-CORE-SA-2016-012: Privilege Escalation in TYPO3 CMS

Categories: TYPO3 CMS created by Helmut Hummel
It has been discovered, that TYPO3 CMS is vulnerable to Privilege Escalation.
Component Type: TYPO3 CMS Release Date: April 12, 2016

Vulnerable subcomponent: Version

Vulnerability Type: Privilege Escalation Affected Versions: Versions 6.2.0 to 6.2.19, 7.6.0 to 7.6.4 and 8.0.0 Severity: Medium Suggested CVSS v2.0: AV:N/AC:L/Au:N/C:P/I:P/A:N/E:P/RL:O/RC:C CVE: not assigned yet

Problem Description: The workspace/ version preview link created by a privileged (backend) user could be abused to obtain certain editing permission, if the admin panel is configured to be shown. A valid preview link is required to exploit this vulnerability.

Solution: Update to TYPO3 versions 6.2.20, 7.6.5 or 8.0.1 that fix the problem described. Credits: Thanks to Helmut Hummel who discovered and reported the issue. General Advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list. General Note: All security related code changes are tagged so that you can easily look them up on our review system.