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Introduction

What does it do?
Extension for subscribing to and unsubscribing in majordomo mailing lists.

Features
• A plugin with two frontend elements

• a form for subscribing and unsubscribing,

• a content element with a confirmation message.

• The plugin verifies mail addresses.

• Subscribers and unsubscribers will get a confirmation mail.

• You can configure the plugin with an interface, you don't need to know nothing about TypoScript.

• The plugin is configurable by editors.

• With DRS - Development Reporting System. It supports you in cases of a unsuccessfully configuration.

• Language support.

What do you need
• A majordomo installation on your server or on a third party server.

• An existing majordomo mailing list.

Update
• Please read the section "Update" below.

Manual in PDF
You find this manual as PDF file at

• doc/manual.pdf

• http://typo3.org/extensions/repository/view/majordomo/current/info/?tx_terfe_pi1%5BdownloadFile%5D=doc
%252Fmanual.pdf

Illustration 1: Manual in PDF format
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Screenshots

Frontend

Illustration 2: A website with the majordomo plugin "form"   Illustration 3: A website with the majordomo plugin "confirm"

Configuration

Illustration 4: Screenshot of the plugin in the backend   Illustration 5: Screenshot of the configuration record

DRS - Development Reporting System

Illustration 6: Logs with email to majordomo and the subscriber
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Installation

Extension Manager
• Download the extension Majordomo form the TYPO3 online repository.

Illustration 7: Import of devlog   Illustration 8: Extension manager with  Majordomo

• If you don't have installed the extension "devlog" (Developer Log), Majordomo will suggest to install it.
You need "devLog", if you want to use the DRS - Development Reporting System.

• Than load the extension Majordomo.

Option: DRS - Development Reporting System
You can enable the DRS - Development Reporting System - with options in the select menu. If you enable it, the DRS will 
report every action of Majordomo to the Developer Log. See the section "Test it! below.

Option Check Mode
You can enable the Check Mode. The Majordomo extension will doesn't send any email and doesn't subrcribe or unsubsribe 
anybody. See the section "Test it! below.

Include Static Template

Illustration 9: Include static  template

1. Select the item "Template" in the web modul.

2. Select your root page or the page in the page tree, where you want to use the majordomo plugin.
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3. Click on the line "Click here to edit ..." below the table template tools.

Illustration 10: Include the Static Template

• Select in the tab [Includes] the item "Majordomo (majordomo)"

• "Majordomo (majordomo)" will be added to the selected items.

Create three Pages

Illustration 11: Three pages

Create three pages like in the example above

• Configuration (it has the uid 378 in our example)

• Form (uid 22)

• Confirmation (uid 21)

Add a Majordomo Configure Record

Illustration 12: Web > List - Add a record   Illustration 13: Select the Majordomo configuration record

Add the Majordomo Configuration Record to the Sysfolder Configuration (uid 378) like in the illustrations above.
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Configure Majordomo

Basics

Illustration 14: Basics

Name your configuration.

Recommended titles are

• Name of the website

• Name of the majordomo list

Form

Illustration 15: Form

Configure some HTML capabilities.

You can set a tab index to your form.

If you are allocates to this field the string "2|3|4" you will get the following tab indexes:

• 2: Input Field: 2

• 3: Unsubscribe Button

• 4: Subscribe Button

Illustration 16: Form with Tab Indexes

7



Installation Majordomo (extKey: majordomo) 

Confirmation

Illustration 17: Confirmation

HTML properties for the content element Confirmation.

Majordomo Server

Illustration 18: Mdom Server

• Majordomo List

• Its the name of the majordomo list.

• Email of the Majordomo Server

• It is the email address of the majordomo server. The majordomo server will process emails to this address as 
commands for subscribing and unsubscribing.

Illustration 19: Email to the majordomo server

• Email of the List Owner

• The email of the list owner. It has to be the majordomo list owner email.

• Default Email in the Input Field of the Form
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• Forbidden Mails (comma separated)

• A comma separated list of emails. The email of the majordomo server, the list owner and the default form email 
will added self-acting.

Email

Illustration 20: Mdom Server

Configuring of the confirmation email.

This email has a template. If you want to edit the template, please read section "Configure the Email Template" below.

The illustration below displays an email to a subscriber in the email client application thunderbird.

Illustration 21: Mail to the subscriber

Remove the Cache
Please remove the TYPO3 cache, if you have changed any value in the Majordomo configuration.
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Configure the Plugins

Confirmation
Edit in the page properties of the page confirmation the general record storage page.

Illustration 22: General Storage Page

Add a plugin to the confirmation page.

Illustration 23: Plugin on the confirmation page

1. Select the Majordomo plugin.

2. Select the content element Confirmation.

3. Select your configuration.

If there isn't any configuration, it can have two reasons:

• You didn't configure a record. Please read the section "Add a  Configure Record" in this case.

• The page configuration record hasn't any general record storage.

Form

Illustration 24: Plugin on the confirmation page

Edit in the page properties of the page form the general record storage page (see example confirmation page above).

Add a plugin to the form page.

1. Select the Majordomo plugin.

2. Select the content element Form.

3. Select your configuration.

4. Select the confirmation page.
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Test it!

Enable the Check Mode

Illustration 25: Test configuration

Choose Admin Tool > Ext Manager and than the extension Majordomo.

1. Enable the DRS - Development Reporting System. Select "All".

2. Enable the Check Mode. Majordomo won't send any email, majordomo won't subscribe or unsubscribe.

3. Klick [Update].

Subscribe to Majordomo

Illustration 26: Subscribe

Subscribe to majordomo with the default email.
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Investigate the DRS Log!

Illustration 27: DRS - Development Reporting System

Choose Admin Tools > Developer Log.

Subscribe with a real Email
Now subscribe with a real Email. E.g your email. Don't take the email in our example: angela.merkel@cdu.de.

Investigate the Developer Log.

Illustration 28: DRS - Development Reporting System with the emails

The DRS displays

1. the email to the majordomo server, 

2. the email to angela.merkel@cdu.de and

3. last but not least an instruction, how to configure the email template, if you like another text.

Complete the Check Mode
Please

• disable the DRS and

• disable the Check Mode.
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Configure the Email Template and HTML Output

Illustration 29: _LOCAL_LANG array in the TypoScript Object Browser

Open the TypoScript Object Browser:

1. Web > Template

2. Select your root page or the page with your majordomo static include template.

3. Select plugin > tx_majodomo_pi1

4. Click on the item you want to edit e.g. [form_title]
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Reference

General Settings
Property: Data type: Description: Default:

_LOCAL_LANG array Default Text for HTML output

plugin.tx_majordomo_pi1 {
  _LOCAL_LANG {
    default {
      form_title                  = Newsletter
      html_subscribe_button_title = Get the\
        newsletter
      html_subscribe_button_value = Subscribe
      ...
    }
  }
}

_CSS_DEFAULT_STYLE text/CSS Default CSS styles for the majrodomo plugin form.

plugin.tx_majordomo_pi1 {
  _CSS_DEFAULT_STYLE (
.tx­majordomo­pi1­buttons {
  padding­top:0.4em;
  clear:both;
  height:2em;
}
.tx­majordomo­pi1­button_left {
  float:left;
  width:49%;
  text­align:left;
}
.tx­majordomo­pi1­button_right {
  text­align:right;
  float:right;
  width:49%;
}
)
}

If you don't need it, please use this snippet in your TypoScript code:

plugin.tx_majordomo_pi1 {
  _CSS_DEFAULT_STYLE >
}

14



Update Majordomo (extKey: majordomo) 

Update

From < 1.0
We replaced the configuration by TypoScript with the configuration by a plugin.

You have to copy your datas from your current TypoScript configuration to the configuration record.

Include Static Table
If you make an update, please load the Include Static Template again.

Illustration 30: Include the Static Template

Delete tx_majordomo_pi1
1. Select the Admin Tools > Install

2. Select Database Analyzer

3. Select Compare

Illustration 31: Comparing with the Database Analyzer

4. Remove the table tx_majordomo_pi1

Illustration 32: Remove tx_majordomo_pi1

Select Compare a second time.

Remove table zzz_tx_majordomo_pi1.

If you like a last check, please click the option [Compare with $TCA].
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Maintaine Your Majordomo Configuration
1. Create a Majordomo configuration record

See the section "Installation > Add a Majordomo Configure Record.

2. Configure your pages with the Majordomo plugins.
Every page with a Majordomo plugin needs a general record storage page.
See section "Installation > Configure the Plugins > Confirmation.

3. Configure the Plugins
See section "Installation > Configure the Plugins > Confirmation and Form.

4. Remove your TypoScript Template, unless you are using TypoScript for removing CSS defaults or for the email 
templates like the code snippet below:

plugin.tx_majordomo_pi1 {
  _LOCAL_LANG {
     default {
       mail_subscribe_subject = YOUR VALUES
       ...
    }
  }
  _CSS_DEFAULT_STYLE >
}

Check Your TypoScript with the DRS
You can check your TypoScript code with the DRS - Development Reporting System. You only have

• to enable the DRS and

• to subscribe to the Majordomo list.

See section "Test it" above.
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Helpful Suggestions
If you have helpful suggestions, feel free to contact me: Dirk Wildt, wildt.at.die-netzmacher.de.

17
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FAQ

SimulateStaticDocuments
There isn't any problem known.

RealUrl
There isn't any problem known.
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Further Information

About the plugin icon
The concept of the icon:

• The letter is symbolizing email and email lists

• The color yellow is the color of Die Netzmacher (http://die-netzmacher.de), the 
company which created the Majordomo extension.

Mojordomo Website and Wikipedia
• Majordomos home site: http://www.greatcircle.com/majordomo/

• Majordomo on Wikipedia: http://de.wikipedia.org/wiki/Majordomo

Other extensions published by Die Netzmacher
•  Browser - Highway to Frontend. The Browser is the fast way for your data to the TYPO3 frontend. It displays 

content from related tables. You need 1 line typoscript for a result list with a search form, a record browser and an a-
z browser. Images are wrapped self-acting. SEO, Search Engine Optimization. DRS supports the TypoScript 
configuration.
http://typo3.org/extensions/repository/view/browser/current/

•  Juridat - Database for Juridical Data. Juridat provides a juridical data base with backend functionality. Juridat is 
out of the box.
http://typo3.org/extensions/repository/view/juridat/current/

•  logical_form: A frontend plugin for evaluating forms. I.e you can evaluate mail addresses.
http://typo3.org/extensions/repository/view/logical_form/current/

•  rm_staticfile: Improve your performance! This extension enables the delete of static files, which where generated 
by nc_staticfilecache. It is a team play with the TYPO3 cache management, ttnews, ttnewscache, sg_newsplus and 
sg_zfelib.
http://typo3.org/extensions/repository/view/delete_staticfile_by_3party/current/

•  seo_dynamic_tag: You can generate values dynamically with this extension especially for the <title>-tag, for the 
<meta>-tag description and the <meta>-tag keywords.
http://typo3.org/extensions/repository/view/seo_dynamic_tag/current/

•  tt_news Marker (extkey: ttnews_marker) enables to add any marker to a tt_news HTML template including links. 
Any marker has the std_wrap property.
http://typo3.org/extensions/repository/view/ttnews_marker/current/

•  tt_news select configuration (extkey: ttnews_selectconf) enables to select tt_news by any SQL clause. The 
extension adds an andWhere clause to the SQL query of the tt_news plugin. I. e. it is possible to display tt_news 
items in dependence on the ownership of a fe_user.
http://typo3.org/extensions/repository/view/ttnews_selectconf/current/
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To-Do List
• Nothing to do.
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Changelog

• 1.1.1
New Sub Versio
- New Features
  - Editing of Email Templates and HTML Templates is simplified

• 1.0.1
Major Version Release
- New Features
  - Configuring with Flexform
  - DRS - Development Reporting System

• 0.0.5
Propering Project

• 0.0.4
Improvement
- Configurable charset for mail
- Changing status from alpha to beta

• 0.0.3
Improvement
Form and buttons got a class

• 0.0.2
Manual
Publishing the English edition

• 0.0.1
Initial Release
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