Cross-Site Scripting in 3rd party library Flowplayer

Categories: TYPO3 CMS 123 Created by Helmut Hummel
It has been discovered, that editors could change, create or delete metadata of files without permission.

Component Type: TYPO3 CMS

Release Date: July 1, 2015

Vulnerable subcomponent: Backend

Vulnerability Type: Cross-Site Scripting

Affected Versions: Versions 6.2.0 to 6.2.13, 7.0.0 to 7.3.0

Severity: Low

Suggested CVSS v2.0: AV:N/AC:L/Au:N/C:P/I:P/A:N/E:F/RL:OF/RC:C

CVE: not assigned yet

Problem Description: It has been discovered, that version of the third party flash player flowplayer is vulnerable to Cross-Site Scripting. No authentication is required to exploit this vulnerability.

Solution: Update to TYPO3 versions 6.2.14 or 7.3.1 that fix the problem described.

Credits: Thanks to Wouter van Dongen who discovered and reported the issue.

General Advice: Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.

General Note: All security related code changes are tagged so that you can easily look them up on our review system.